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ANALISIS DATA

Mendeskripsikan

Memodelkan  
hubungan

Membandingkan
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Analisis Deskriptif

Analisis Deskriptif adalah analisis yang bertujuan 
untuk memberikan gambaran (deskripsi) tentang 
suatu data:
➢ Rata-rata (mean)
➢ Jumlah (sum)
➢ Simpangan baku (standard deviation), Varians 

(variance)
➢ Rentang (range)
➢ Nilai minimum dan maximum, dsb.



Latihan 
1

Nama Gender Pekerjaan Pendidikan Penghasilan

Ali Pria Swasta SD 675500

Andi Pria Swasta S1 825999

Nana Wanita PNS S1 900000

Tatok Pria Petani SMP 543445

Didi Pria Pedagang SMP 678775

Dini Wanita PNS SMA 887556

Ahmad Pria Swasta SD 876555

Wati Wanita Petani SD 445665

Asep Pria PNS SD 644335

Wita Wanita PNS S2 1500000

Cecep Pria Petani SD 448335

Neni Wanita Pedagang SD 367421

Dewi Wanita Swasta SD 765454

Sandra Wanita Swasta S2 2500000

Jamal Pria Pedagang S1 1200000

Rina Wanita Petani SMP 555555

Gama Pria Petani SMP 650273

Ani Wanita Swasta SD 800500

Eko Pria Petani SD 480321

Dono Pria Pedagang SD 864123
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Menggunakan Excel

Menggunakan fungsi descriptive statistics di Data Analysis, dengan menggunakan add-in 

Analysis ToolPak, jika belum ada ditambahkan dengan cara:

1. Buka Excel

2. Klik menu File > Options

3. Pilih tab Add-ins

4. Di bagian bawah, pada dropdown Manage, pilih Excel Add-ins > klik Go...

5. Centang Analysis ToolPak > klik OK.

6. Jika diminta, izinkan Excel untuk menginstal (jika belum terinstal).
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Langkah - Langkah

1. Koding data

Koding
Gender 
1 = Pria 2= Wanita
Pekerjaan 
1 = PNS
2= Swasta
3= Petani
4= Pedagang
Pendidikan
1= SD
2= SMP
3= SMA
4= S1
5= S2

Nama Gender Pekerjaan Pendidikan Penghasilan

Ali 1 2 1 675500

Andi 1 2 4 825999

Nana 2 1 4 900000

Tatok 1 3 2 543445

Didi 1 4 2 678775

Dini 2 1 3 887556

Ahmad 1 2 1 876555

Wati 2 3 1 445665

Asep 1 1 1 644335

Wita 2 1 5 1500000

Cecep 1 3 1 448335

Neni 2 4 1 367421

Dewi 2 2 1 765454

Sandra 2 2 5 2500000

Jamal 1 4 4 1200000

Rina 2 3 2 555555

Gama 1 3 2 650273

Ani 2 2 1 800500

Eko 1 3 1 480321

Dono 1 4 1 864123



Pengolahan, Analisis dan Interpretasi Data 6

Langkah - Langkah

2. Klik Menu Data > Data Analysis > Descriptive Analysis > Ok

Misal 
Penghasilan
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Langkah - Langkah

Column1

Mean 830490.6
Standard Error 106275.1485
Median 722114.5
Mode #N/A
Standard Deviation 475276.9128
Sample Variance 2.25888E+11
Kurtosis 7.94054471
Skewness 2.552110048
Range 2132579
Minimum 367421
Maximum 2500000
Sum 16609812
Count 20

Mean Rata-rata 
penghasilan

830490.6

Standard Error Galat standard rata- 
rata

Nilai kecil rata –rata 
lebih representatif

Median Nilai Tengah distribusi 7221114.5

Mode Nilai yang sering 
muncul

Standard Deviation Sebaran data dari 
rata-rata

Kurtosis Ketajaman puncak Kurtosis normal 3, lebih 
dari 3 sangat tajam 
(lebih banyak nilai 
ekstrim)

Skewness Kemiringan distribusi Nilai positif (kekanan, 
lebih banyak nilai 
rendah, beberapa 
sangat tinggi)

Range Rentang nilai (selisih)

Min – Max - sum Nilai tertinggi, nilai 
terendah – nilai total
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1. Block semua data (termasuk 
header)

2. Klik Insert > pivot table

3. Pilih Lokasi pivot table > ok

4. Drag Gender ke  bagian row

5. Drag Penghasilan ke bagian 
values (ubah ke average dan 
count)

Analisis Penghasilan Berdasarkan Gender
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1. Block semua data (termasuk 
header)

2. Klik Insert > pivot table

3. Pilih Lokasi pivot table > ok

4. Drag Pendidikan ke  bagian row

5. Drag Penghasilan ke bagian 
values (ubah ke average dan 
count)

Analisis Penghasilan Berdasarkan Pendidikan
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ANALISIS  KORELASI 

• Bernilai antara –1 s/d +1
• Tanda koefisien menunjukkan arah 

hubungan kedua variabel
• Besarnya koefisien menunjukkan keeratan 

hubungan kedua variabel
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Tahun Sopir  mengantuk Jumlah kecelakaan
2017 4 192
2018 3 91
2019 15 229
2020 8 200
2021 6 183
2022 10 230
2023 9 208

CONTOH DATA
TUJUAN PENELITIAN:
• Mengetahui adanya korelasi/hubungan (keeratan) 

antara jumlah kejadian kecelakaan lalu lintas yang 
disebabkan karena sopir mengantuk

Rumus Manual
=CORREL(sopir mengantuk, jumlah 
kecelakaan)

HASIL
r= 0,758 (artinya??)

KORELASI PEARSON 

Rumus Toolpax :
Buka Data
Data Analysis > Correlation > Ok 
> Blok Range sopir mengantuk 
dan jumlah kecelakaan
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KORELASI PEARSON 
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Membuat Grafik Scatter

• Blok Data (judul dan isinya): “sopir 
mengantuk” dan “Jumlah 
kecelakaan”

• Sisipkan Grafik Scatter > insert 
Scatter (X,Y) or Buble chart > klik 
scatter with only markers

• Tambahkan Garis tren dan Nilai R²
• Di panel kanan, pilih linear > 

centang Display Equation on Chart 
> centang Display R-Squared value 
on chart 
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CONTOH DATA

TUJUAN PENELITIAN:
Mengetahui hubungan 

(keeratan) antara 
sopir mengantuk dan 

jumlah kecelakaan

KORELASI SPEARMAN 

Tahun
Jumlah Kecelakaan

Waktu
00 sd 
06.00

06.00 s.d. 
12.00

12.00 sd 
18.00

18.00 s.d. 
24.00

2008 67 7 20 21 19
2009 34 4 13 10 7
2010 39 6 11 13 9
2011 72 11 20 23 18
2012 81 14 18 26 23

LANGKAH 1.
• Koding waktu kecelakaan
 - 00.00 sd 06.00 = 1
 - 06.00 sd 12.00 = 2
 - 12.00 sd 18.00 = 3
 - 18.00 sd 24.00 = 4
Susun menurun data yang di miliki 
sesuai kategori waktu 

Jumlah kecelakaan Waktu
7 1
4 1
6 1

11 1
14 1
20 2
13 2
11 2
20 2
18 2
21 3
10 3
13 3
23 3
26 3
19 4
7 4
9 4

18 4
23 4
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KORELASI SPEARMAN 

Langkah 2 : Tambahkan kolom untuk Rank Jumlah 
Kecelakaan dan Waktu
Langkah 3: Hitung Rank Masing- masing dengan 
rumus = RANK.AVR
Langkah 4: Hitung korelasinya
Dengan toolpax > data > data analysis > 
Correlation
Dengan rumus = CORREL

Jumlah kecelakaan Waktu RANK Kecelakaan RANK Waktu
7 1 3.5 3
4 1 1 3
6 1 2 3

11 1 7.5 3
14 1 11 3
20 2 15.5 8
13 2 9.5 8
11 2 7.5 8
20 2 15.5 8
18 2 12.5 8
21 3 17 13
10 3 6 13
13 3 9.5 13
23 3 18.5 13
26 3 20 13
19 4 14 18
7 4 3.5 18
9 4 5 18

18 4 12.5 18
23 4 18.5 18

Korelasi
0.373114596

RANK 
Kecelakaa

n
RANK 
Waktu

RANK Kecelakaan 1
RANK Waktu 0.373115 1
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REGRESI

Tujuan: mengetahui pengaruh antara variable X dan Y

Data yang digunakan berupa data sekunder mengenai jumlah angka kecelakaan dan faktor 
penyebab kecelakaan yang terjadi di Kota Pekanbaru selama 7 tahun terakhir (2017-2023). Adapun 
faktor penyebab kecelakaan yang diolah dalam penelitian ini berupa lima variabel dari sembilan 
variabel yaitu jumlah lengah (X1), jumlah letih (X2), jumlah mengantuk (X3), jumlah tidak tertib (X4) 
dan jumlah batas kecepatan (X5).

Tahun Jumlah lengah (X1) Jml letih (X2) jml mengantuk (X3) jml tidak tertib (X4) jumlah kecelakaan (Y)
2017 90 7 4 30 192
2018 86 6 3 28 91
2019 121 19 15 32 229
2020 93 19 8 26 200
2021 84 18 6 32 183
2022 143 15 10 25 230
2023 137 25 9 16 208
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REGRESI

Langkah dengan Excel:
1. Klik Data > Data Analysis > Regression
2. Input Y range
3. Input X range
4. Klik Ok

Coefficien
ts

Standard 
Error t Stat P-value

Lower 
95%

Upper 
95%

Lower 
95.0%

Upper 
95.0%

Intercept -158.475 388.6921 -0.40771 0.722986 -1830.88 1513.932 -1830.88 1513.932
Jumlah 
lengah 
(X1) 1.450068 1.971595 0.735479 0.538604 -7.03302 9.933157 -7.03302 9.933157
Jml letih 
(X2) 4.162286 5.624119 0.740078 0.536337 -20.0363 28.36092 -20.0363 28.36092
jml 
mengantu
k (X3) -1.57685 13.4061 -0.11762 0.917115 -59.2586 56.10493 -59.2586 56.10493
jml tidak 
tertib (X4) 5.195819 8.126348 0.639379 0.588038 -29.769 40.16067 -29.769 40.16067

Dilihat dari P-value nya
Signifikan jika P < 0.05



Pengolahan, Analisis dan Interpretasi Data 18

One Sample T-Test

Tujuan: mengetahui adanya signifikansi perbedaan

Contoh Data

No. 
Laporan Waktu Respons (Menit)

No. 
Laporan Waktu Respons (Menit) No. Laporan Waktu Respons (Menit)

1 14.8 11 16.0 21 15.1
2 16.2 12 13.9 22 15.9
3 15.0 13 15.8 23 14.2
4 13.5 14 15.2 24 16.9
5 17.1 15 13.0 25 15.4
6 14.9 16 17.5
7 15.5 17 14.5
8 16.8 18 15.6
9 14.0 19 16.5

10 15.3 20 14.7

Apakah data ini menunjukkan bahwa rata-rata waktu respons polisi 
di Kota Bahagia berbeda secara signifikan dari standar internal 15 

menit yang ditetapkan???
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One Sample T-Test

Langkah- Langkah:
1. Masukan data waktu respon (mis kolom A)
2. Masukan data pembanding (mis. Kolom B)
3. Buka data > data analysis > t-Test: Two-Sample 

Assuming Equal Variances
4. Masukan:
       Variable 1 Range: Kolom A (data waktu respons)
       Variable 2 Range: Kolom B (nilai pembanding)
       Hypothesized Mean Difference: 0       

No Laporan Waktu Respon Data Pembanding
1 14.8 15
2 16.2 15
3 15.0 15
4 13.5 15
5 17.1 15
6 14,9 15
7 15.5 15
8 16.8 15
9 14.0 15

10 15.3 15
11 16.0 15
12 13.9 15
13 15.8 15
14 15.2 15
15 13.0 15
16 17.5 15
17 14.5 15
18 15.6 15
19 16.5 15
20 14.7 15
21 15.1 15
22 15.9 15
23 14.2 15
24 16.9 15
25 15.4 15

t-Test: Two-Sample Assuming Equal Variances

Waktu Respon Data Pembanding
Mean 15.332 15
Variance 1.303933333 0
Observations 25 25
Pooled Variance 0.651966667
Hypothesized Mean Difference 0
df 48
t Stat 1.453718757
P(T<=t) one-tail 0.076265899
t Critical one-tail 1.677224196
P(T<=t) two-tail 0.152531797
t Critical two-tail 2.010634758
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Uji T Independent Sample T-Test

H0: Rata-rata tingkat kebisingan pagi  dan malam  sama.
H1: Rata-rata tingkat kebisingan pagi  dan malam tidak sama.
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Uji T Independent Sample T-Test

Langkah- Langkah:
1. Masukan data masing – masing, kolom A untuk 

kebisingan kolom B untuk  waktu
2. Buka data > data analysis > t-Test: Two-Sample 

Assuming Equal Variances
3. Masukan:
       Variable 1 Range: pilih data pagi
       Variable 2 Range: pilih data malam
       Hypothesized Mean Difference: 0 > ok       

t-Test: Two-Sample Assuming Equal Variances

Kebisingan Kebisingan
Mean 73.9425 72.41666667
Variance 3.221675 19.85669697
Observations 12 12
Pooled Variance 11.53918598
Hypothesized Mean Difference 0
df 22
t Stat 1.100259525
P(T<=t) one-tail 0.141556461
t Critical one-tail 1.717144374
P(T<=t) two-tail 0.283112923
t Critical two-tail 2.073873068

Kebisingan Waktu
74.61 1
77.51 1
75.64 1
72.36 1
72.95 1
70.87 1
73.13 1
73.10 1
72.54 1
75.02 1
74.28 1
75.30 1

Kebisingan Waktu
77.41 2
76.08 2
76.24 2
73.77 2
76.32 2
75.81 2
69.53 2
70.96 2
70.44 2
65.12 2
64.13 2
73.19 2

TABULASI DATA 
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Paired Sample T-Test

Hipotesis
H0: Pretest = Post Test (sosialisasi tidak efektif)
H1: Pretest ≠ Post Test (sosialisasi efektis)
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Paired Sample T-Test

Langkah- Langkah:
1. Buka data > data analysis > t-Test: Paired Two 

Sample for Means, lalu klik OK.
2. Masukan:
       Variable 1 Range: Block nilai Pre test
       Variable 2 Range: Blok Nilai post test
       Hypothesized Mean Difference: 0 > ok       

Pre Test Post Test
54 92
60 91
62 90
59 83
57 80
55 79
59 82
55 73

t-Test: Paired Two Sample for Means

Pre Test Post Test
Mean 57.625 83.75
Variance 7.982142857 45.07142857
Observations 8 8
Pearson Correlation 0.408593349
Hypothesized Mean Difference 0
df 7
t Stat -12.05801084
P(T<=t) one-tail 3.07789E-06
t Critical one-tail 1.894578605
P(T<=t) two-tail 6.15577E-06
t Critical two-tail 2.364624252

•p-value (two-tail) = 0.0000061 jauh lebih 
kecil dari α = 0.05.
•t Stat = -12.06 (nilai absolutnya jauh lebih 
besar dari t Critical = 2.3646)
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One Way Anova

Tujuan Penelitian: ingin mengetahui pelanggaran traffic Light di simpang 

bendogantungan jalan raya Jogya Solo. Secara spesifik tulisan ini bertujuan untuk 

mengetahui beda pelanggaran lalu lintas berdasarkan jenis pelanggarannya. 

banyaknya 

pelanggaran 

arah lurus

banyaknya 

pelanggaran

arah belok kanan

banyaknya 

pelanggara

n arah 

lurus

banyaknya 

pelanggaran

arah belok 

kanan

banyaknya 

pelanggara

n arah lurus

banyaknya 

pelanggaran

arah belok 

kanan

14 24 40 73 67

20 36 147 64 170

53 44 90 129 169

15 22 18 11 26

37 50 144 243 317

39 42 62 128 231

52 65 68 81 209

39 48 159 118 317

79 56 103 139 309

0 30 14 8 12

10 14 128 180 205

42 42 2 124 274

Jogja solo sisi baratJogja solo sisi timurKi  Ageng Pandanaran

15

86

1

46

89

81

31

76

67

14

63

69
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One Way Anova

Langkah- Langkah:
1. Susun data berdasarkan format kolom sesuai 

dengan nama jalan
2. Klik Data > Data Analysis > ANOVA: Single factor
3. Input Range: 
▪ pilih semua data 
▪ Grouped By: Columns.
▪ Centang Labels in First Row jika ada nama kolom.
▪ Output Range: pilih tempat hasil ditampilkan.

Banyaknya pelanggaran arah lurus
Jalan 1 Jalan 2 Jalan 3

14 40 73
20 147 64
53 90 129
15 18 11
37 144 243
39 62 128
52 68 81
39 159 118
79 103 139
0 14 8

10 128 180
42 2 124

SUMMARY
Groups Count Sum Average Variance

Jalan 1 12 400 33.33333 501.5151515
Jalan 2 12 975 81.25 3099.295455
Jalan 3 12 1298 108.1667 4442.333333

ANOVA
Source of Variation SS df MS F P-value F crit

Between Groups 34482.16667 2 17241.08 6.430725397 0.004381 3.284918
Within Groups 88474.58333 33 2681.048

Total 122956.75 35
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One Way Anova
Banyaknya pelanggaran arah belok
Jalan 1 Jalan 2 Jalan 3

24 31 67
36 76 170
44 67 169
22 14 26
50 63 317
42 69 231
65 46 209
48 89 317
56 81 309
30 15 12
14 86 205
42 1 274

Anova: Single Factor

SUMMARY
Groups Count Sum Average Variance

Jalan 1 12 473 39.41667 221.5379
Jalan 2 12 638 53.16667 950.1515
Jalan 3 12 2306 192.1667 11839.61

ANOVA
Source of Variation SS df MS F P-value F crit

Between Groups171370.5 2 85685.25 19.75635 2.28E-06 3.284918
Within Groups143124.3 33 4337.098

Total 314494.8 35

Keterangan Arah Lurus Belok Kanan

Jalan 1 (rata-rata) 33.33 39.42

Jalan 2 (rata-rata) 81.25 53.17

Jalan 3 (rata-rata) 108.17 192.17

Variansi dalam (MS Within) 2,681.05 4,337.10

F hitung 6.43 19.76

F kritis 3.28 3.28

P-value 0.0044 2.28×10⁻⁶

Kesimpulan Signifikan Sangat signifikan
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Two Way Anova
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Two Way Anova

Perkotaan Suburban Pedesaan

Jenis 
kejahatan

Persepsi Keamanan (Skala 1-
10) Jenis kejahatan

Persepsi Keamanan (Skala 1-
10) Jenis kejahatan

Persepsi Keamanan (Skala 1-
10)

Pencurian 6 Pencurian 7 Pencurian 8
Pencurian 7 Pencurian 8 Pencurian 9
Pencurian 5 Pencurian 7 Pencurian 8
Pencurian 6 Pencurian 8 Pencurian 7
Pencurian 7 Pencurian 9 Pencurian 9
Narkoba 4 Narkoba 6 Narkoba 5
Narkoba 5 Narkoba 7 Narkoba 6
Narkoba 4 Narkoba 6 Narkoba 5
Narkoba 5 Narkoba 7 Narkoba 4
Narkoba 3 Narkoba 5 Narkoba 6
Kekerasan 
Jalanan 5 Kekerasan Jalanan 7 Kekerasan Jalanan 7
Kekerasan 
Jalanan 4 Kekerasan Jalanan 6 Kekerasan Jalanan 6
Kekerasan 
Jalanan 5 Kekerasan Jalanan 7 Kekerasan Jalanan 7
Kekerasan 
Jalanan 6 Kekerasan Jalanan 8 Kekerasan Jalanan 8
Kekerasan 
Jalanan 4 Kekerasan Jalanan 6 Kekerasan Jalanan 7
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Two Way Anova

Langkah- Langkah:
1. Susun table dengan kolom wilayah dan row jenis kejahatan
2. Klik Data > Data Analysis > ANOVA: Two Factor with Replication
3. Input Range: 
▪ pilih semua data 
▪ Row per sample isi 5 (5 kali pengulangan)
▪ Pilih output options > ok

Perkotaan Suburban Pedesaan
Pencurian 6 7 8
Pencurian 7 8 9
Pencurian 5 7 8
Pencurian 6 8 7
Pencurian 7 9 9
Narkoba 4 6 5
Narkoba 5 7 6
Narkoba 4 6 5
Narkoba 5 7 4
Narkoba 3 5 6
Kekerasan Jalanan 5 7 7
Kekerasan Jalanan 4 6 6
Kekerasan Jalanan 5 7 7
Kekerasan Jalanan 6 8 8
Kekerasan Jalanan 4 6 7
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Two Way Anova
Anova: Two-Factor With Replication

SUMMARY Perkotaan Suburban Pedesaan Total
Pencurian
Count 5 5 5 15
Sum 31 39 41 111
Average 6.2 7.8 8.2 7.4
Variance 0.7 0.7 0.7 1.4

Narkoba
Count 5 5 5 15
Sum 21 31 26 78
Average 4.2 6.2 5.2 5.2
Variance 0.7 0.7 0.7 1.314286

Kekerasan Jalanan
Count 5 5 5 15
Sum 24 34 35 93
Average 4.8 6.8 7 6.2
Variance 0.7 0.7 0.5 1.6

Total
Count 15 15 15
Sum 76 104 102
Average 5.066667 6.933333 6.8
Variance 1.352381 1.066667 2.171429

ANOVA
Source of Variation SS df MS F P-value F crit

Sample 36.4 2 18.2 26.85246 7.29E-08 3.259446
Columns 32.53333 2 16.26667 24 2.38E-07 3.259446
Interaction 3.466667 4 0.866667 1.278689 0.296435 2.633532
Within 24.4 36 0.677778

Total 96.8 44
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